package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ADOI.*OP_.*\txt$`)
var str = `ADOI1OP_2.txt`
var substitution = "($1$2$3) $4$5$6-$7$8$9$10"
fmt.Println(re.ReplaceAllString(str, substitution))
}