package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+,\s*\d+(?:\.\d+)?$`)
var str = `123,123.4
1234, 1234
123, 123.45
abd, 123
123, abc
abc, abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}