import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+,\\s*\\d+(?:\\.\\d+)?$";
final String string = "123,123.4\n"
+ "1234, 1234\n"
+ "123, 123.45\n"
+ "abd, 123\n"
+ "123, abc\n"
+ "abc, abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}