package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\$(\d+)[\,]*([\.]*\d*)`)
var str = `a|b|c
$1,000|hi,you|$45.43
$300.03|$MS2|$55,000`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}