re = /^(?<time>\d{4}-\d{1,2}-\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}.\d{3})\s+(?<level>[^\s]+)\s+(?<pid>\d+).*?\[\s+(?<thread>.*)\]\s+(?<class>.*)\s+:\s+(?<message>.*)/
str = '2016-01-11 16:14:32.474 INFO 1 --- [ main] fluentd.FluentdBootApplication : Starting FluentdBootApplication on 750117306ae6 with PID 1 (/app.jar started by root in /)
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end