$re = '/\b(?!(?:[^\S\r\n]*\w){21})\w+(?:\s+\w+){0,2}(?=$|[\r\n])/';
$str = 'The early bird catches the worm
Here we have a supercalifragilisticexpialidocious sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);