$re = '/#([\p{L}\d_]+)/m';
$str = '#جافا #Java #JAVA3 #جافا3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);