#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$\{.*?\}"
Local $sString = "{" & @CRLF & _
" "type" : "id"," & @CRLF & _
" "id" : ${idOf('/tar/check/inof/high1')}," & @CRLF & _
" "details" : [" & @CRLF & _
" {" & @CRLF & _
" "name" : "Sanio"," & @CRLF & _
" "sig" : "DA123QW"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "name" : "Tarer"," & @CRLF & _
" "sig" : "BAWE3QW"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "name" : "Kadek"," & @CRLF & _
" "sig" : "KSWE2J"" & @CRLF & _
" }," & @CRLF & _
" ]" & @CRLF & _
" },"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")