#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^.+(video\/|\/watch\?v=|embed\/)([a-z0-9_?=-]+)$"
Local $sString = "http://www.youtube.com/video/ZNvzVScj8ws" & @CRLF & _
"https://www.youtube.com/watch?v=ZNvzVScj8ws" & @CRLF & _
"http://www.youtube-nocookie.com/embed/ZNvzVScj8ws"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")