$re = '/(?:SERVICE_NAME|SID)\s?=\s?(.+?)\)/m';
$str = 'SERVICE_NAME=db1)
SID=db1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);