use strict;
my $str = 'Foo text ADY123 bar
foo AD12ADY baz
bak 1HGER_2 bam baz 128D foo
lorem ipsum 128878P foo bar
again more text 145-DE-FR2 lol foo bar
this is not even matched BICYCLE lel
not this one either 183-329-193 cool
wow 3123123 not this either!
';
my $regex = qr/\b((?:[a-z]+\S*\d+|\d\S*[a-z]+)[a-z\d_-]*)\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}