#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(value)(\d+)"
Local $sString = "LeaveThisInArray" & @CRLF & _
"value1" & @CRLF & _
"value2"
Local $sSubst = "$2:$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)