use strict;
my $str = 'LeaveThisInArray
value1
value2';
my $regex = qr/^(value)(\d+)/mp;
my $subst = '$2:$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";