using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/repo\/requirements\/?.*?$|^\/repo\/requirements\.txt$";
string input = @"/repo/requirements/somefile
/repo/requirements/requirements.txt
/repo/requirements.txt
/repo/apps/myapp/requirements/txt
/repo/apps/myapp/requirements.txt
/repo/apps/requirements/requirements.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}