package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/repo\/requirements\/?.*?$|^\/repo\/requirements\.txt$`)
var str = `/repo/requirements/somefile
/repo/requirements/requirements.txt
/repo/requirements.txt
/repo/apps/myapp/requirements/txt
/repo/apps/myapp/requirements.txt
/repo/apps/requirements/requirements.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}