const regex = /^\/repo\/requirements\/?.*?$|^\/repo\/requirements\.txt$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/repo\\\/requirements\\\/?.*?$|^\\\/repo\\\/requirements\\.txt$', 'gm')
const str = `/repo/requirements/somefile
/repo/requirements/requirements.txt
/repo/requirements.txt
/repo/apps/myapp/requirements/txt
/repo/apps/myapp/requirements.txt
/repo/apps/requirements/requirements.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}