# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)=\s*$/=$null/gi;t' <<< "$a=5
$b=\"\"
$c=
$d=555
"