use strict;
my $str = '$a=5
$b=""
$c=
$d=555
';
my $regex = qr/(?m)=\s*$/ip;
my $subst = '=$null';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";