const regex = /^(070|080|081|090|091)[0-9]{8}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(070|080|081|090|091)[0-9]{8}$', 'i')
const str = `07098765432`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}