#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?(cat.*?){1})cat"
Local $sString = "bear cat goose mouse horse pig cat foo cat cow"
Local $sSubst = "\1Bull"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)