using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?(cat.*?){1})cat";
string substitution = @"\1Bull";
string input = @"bear cat goose mouse horse pig cat foo cat cow";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}