re = /^(.*?(cat.*?){1})cat/m
str = 'bear cat goose mouse horse pig cat foo cat cow'
subst = '\\1Bull'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result