#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+?|)(tir(a|o)?|dispar(a|o)?|lanz(a|o)?|mape(a|o)?|us(o|a)?)(.+?|)(sonda|planeta|burbuja|mater?)(.+?|)\?"
Local $sString = "Alguien tiene alguna imagen donde se vea donde tirar las sondas para escanear planetas?" & @CRLF & _
"" & @CRLF & _
"tiro sondas?" & @CRLF & _
"" & @CRLF & _
"lanzar sondas?" & @CRLF & _
"" & @CRLF & _
"lanzo sonda?" & @CRLF & _
"" & @CRLF & _
"mapear planetas?" & @CRLF & _
"" & @CRLF & _
"uso las sondas?" & @CRLF & _
"" & @CRLF & _
"disparan sondas?" & @CRLF & _
"" & @CRLF & _
"usas las sondas?" & @CRLF & _
"" & @CRLF & _
"usa las sondas?" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"usais las sondas?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")