# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*).{11}\..*$/$1/g;t' <<< "London_7382904821.jpg"