const regex = /\.(?![^.]+$)|[^0-9.]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?![^.]+$)|[^0-9.]', 'g')
const str = `£63.000.00`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);