using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([123]),((?!\1)[123]),((?!\1|\2)[123])";
string input = @"1,2,3; 3,2,1; 2,1,3; 2,1,3;
1,1,1; 1,2,2; 1,3,3; 3,3,1; 2,3,3;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}