import Foundation
let pattern = #"^([^(\/]+)(?:\((.*?)\))?\/(?:([^?]+))?\?select=(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Table_name(1)/field?select=Name
Table_name/field?select=Name
bla-bla-bla(123)/zsdfgdsg?select=Name2
bla-bla-bla(897646)/rytutuityi?select=Name3
Table_name(1)/?select=Name
Table_name(1)/?select=Name
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)