import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(7656119)([0-9]{10})";
final String string = "http://steamcommunity.com/profiles/7656119xxxxxxxxxx OR 7656119xxxxxxxxxx\n"
+ "//steamcommunity.com/profiles/76561198253871432\n"
+ "765611982538714325 - false\n"
+ "7656119825387143288 -false\n"
+ "7656119825387143 - false\n"
+ "76561198253871432 -true\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}