// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\p{L}\p{Nd}]+)").unwrap();
let string = "jshdgudgdi^dlnhddhjdhdhdhdkjdh
&%$#@#$%^&*()
dndjjskjdlkdjnskjdkjd
nshhd
%#$%01763543892
English:
Finally done, this was the 6th or sixth test.
Russian:
Наконец сделано , это было 6-й или шестой тест .
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}