$re = '/\bA(?: \K)?\S+/';
$str = 'Given: A23+ returns A23+
Given: A 23+ returns 23+
Given: A.rg23- returns A.rg23-
Given: A .rg23- returns .rg23-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);