using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"B(?<StartByte>[0-9])(?:.(?<StartBit>[0-7]))?(?:<<(?<LeftShift>[0-9]))?\|?";
string input = @"B0<<8|B0|B1.6<<8
B0.7<<8
(B0.7-B0.0)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}