re = /[^\/]+\//
str = 'customer-service/tweep/cs/gsergsergrs/2017-20190Course-Schedule.pdf'
subst = '---/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result