import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^127\\.|^[0:]*::1[[:space:]]";
final String string = "127.0.0.1 localhost localhost.localdomain\n"
+ "127.0.1.1 mybox mybox.home\n"
+ "172.0.1.1 yourbox yourbox.office\n"
+ "1.2.127.1 127.box\n"
+ "::1 localhost mybox mybox.home\n"
+ "00::1 mybox.lo\n"
+ "12::1 invalid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}