use strict;
my $str = '127.0.0.1 localhost localhost.localdomain
127.0.1.1 mybox mybox.home
172.0.1.1 yourbox yourbox.office
1.2.127.1 127.box
::1 localhost mybox mybox.home
00::1 mybox.lo
12::1 invalid';
my $regex = qr/^127\.|^[0:]*::1[[:space:]]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}