package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`a.*href="(([^.]+\.)+[^.]*)"`)
var str = `<a href="2015-mail.com.html">2015-mail.com</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}