const regex = /a.*href="(([^.]+\.)+[^.]*)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a.*href="(([^.]+\\.)+[^.]*)"', '')
const str = `<a href="2015-mail.com.html">2015-mail.com</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}