using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\(.*\)\s*";
string input = @"RomFile01(US).rom
RomFile02 (EU).rom
RomFile03 (USA) .rom
RomFile04 (Japan) .rom
RomFile05 (Europe) .rom";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}