re = /\S.{0,39}(?<=\S)(?!\S)/m
str = 'abcd (efghij # / klmno (# #)
blah blah etc etc words and more words and yet more words. What about these words?
And some more text for this string so that we can test things out.
test test test test test
a
abcd (efghij # / klmno (# #)
blah blah etc etc words and more words and yet more words. What about these words?
And some more text for this string so that we can test things out.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end