use strict;
my $str = 'In this case, $url will indeed contain http://example.com/whatever.jpg. But what happens when you start getting HTML like this:
<img src=\'http://example.com/whatever.jpg\'>
or
<img src=http://example.com/whatever.jpg>
or
<img border=0 src="http://example.com/whatever.jpg">
or
<img
src="http://example.com/whatever.jpg">
or you start getting false positives from
<!-- // commented out
<img src="http://example.com/outdated.png">
-->
<asd ASD=asd>
<!-- // commented out <img src="http://example.com/outdated.png"> -->
No quotes:
<iframe src=test.html target=xyz></iframe>
Self-closing tag:
<a href=test.html target=xyz/>
Self closing tag with a space before closure:
<a href=test.html target=xyz />
Double quotes:
<a href="test.html" target="xyz">
Single quotes:
<a href=\'test.html\' target=\'xyz\'>
Escaping double quotes:
<a href="test.html?val=1" title="\\"No rules exist\\" Andre Breton\'s quote">
Escaping single quotes (also with spaces between equals signs):
<a href = "test.html?val=1" title = \'Charlie\\\'s Angels\'>
Tag without opening (ignore attributes):
a href = "test.html?val=1" title=\'Charlie\\\'s Angels\'>
Tag without closure (ignore attributes):
<a href = "test.html?val=1" title=\'Charlie\\\'s Angels\'
';
my $regex = qr/(?:\<\!\-\-(?:(?!\-\-\>)\r\n?|\n|.)*?-\-\>)|(?:<(\S+)\s+(?=.*>)|(?<=[=\s])\G)(?:((?:(?!\s|=).)*)\s*?=\s*?[\"']?((?:(?<=\")(?:(?<=\\)\"|[^\"])*|(?<=')(?:(?<=\\)'|[^'])*)|(?:(?!\"|')(?:(?!\/>|>|\s).)+))[\"']?\s*)/isxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}