using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<symbol>[0-9]?[A-Z]+)(?P<contract>[FGHJKMNQUVXZ]+\d{1,2}) (?P<yellow_key>(COMB )?Comdty)";
string input = @"VBYU4 Comdty";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}