$re = '/^([0-9]+\.)+[0-9]+ /m';
$str = '1.0 ...
...
2.4.3 ...
...
6.18.21.8 ...
...
...1.0 ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);