#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " +<metaData>[\S\s]+<\/metaData>\s"
Local $sString = " <usedInTechSheet>false</usedInTechSheet>" & @CRLF & _
" <usedInCompositionList>false</usedInCompositionList>" & @CRLF & _
" <usedInRequestForm>false</usedInRequestForm>" & @CRLF & _
" <metaData>" & @CRLF & _
" <dateCreation>2014-10-01</dateCreation>" & @CRLF & _
" <dateMaj>2021-04-27</dateMaj>" & @CRLF & _
" </metaData>" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")