import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " +<metaData>[\\S\\s]+<\\/metaData>\\s";
final String string = " <usedInTechSheet>false</usedInTechSheet>\n"
+ " <usedInCompositionList>false</usedInCompositionList>\n"
+ " <usedInRequestForm>false</usedInRequestForm>\n"
+ " <metaData>\n"
+ " <dateCreation>2014-10-01</dateCreation>\n"
+ " <dateMaj>2021-04-27</dateMaj>\n"
+ " </metaData>\n"
+ " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}