// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href=".*?([\w-]+\.pdf)""#).unwrap();
let string = "<a class=\"btn btn-small pad-button\" href=\"/Tests/English/english_2011_summer_A-Q_b.pdf\">eng1</a><br>
<a href=\"english_2011_summer_A-Q_c.pdf\">eng2</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}