#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\d{8}"
Local $sString = "07016"
Local $sSubst = "^\d{15}[0-9]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)