$re = '/^\d{8}/';
$str = '07016';
$subst = "^\d{15}[0-9]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;