import Foundation
let pattern = #"^\d{8}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"07016"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"^\d{15}[0-9]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)