package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\bsigned.*`)
var str = `The document was signed on July 12
The document was signed by Charlie
This document was assigned to John
The document was preassigned to Amanda`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}