re = /.*\bsigned.*/m
str = 'The document was signed on July 12
The document was signed by Charlie
This document was assigned to John
The document was preassigned to Amanda'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end