// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\bsigned.*").unwrap();
let string = "The document was signed on July 12
The document was signed by Charlie
This document was assigned to John
The document was preassigned to Amanda";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}